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Preface

Introduction to EZQ-EXPORT

The American Society of Composers, Authors and Publishers (ASCAP) originally provided the EZQ tool in order to allow cue sheet providers to supply cue sheets electronically. The EZQ application enables users to create and submit cue sheets electronically to ASCAP and BMI, while building a database of commonly used series, programs, song titles and members. The EZQ application was well received and widely used by numerous organizations. In fact, many organizations had several users each with their own instance of the EZQ application. Moreover, many organizations decided to segment their data in various ways (i.e. by season, by series, etc.) This variety in implementation resulted in the proliferation of numerous EZQ databases even within the very same organization. Eventually, organizations identified the need for a platform-independent repository for their data. The RapidCue Internet based cue sheet system addresses that very need. Hence, the advantage of allowing EZQ users to migrate all of their existing EZQ database data into the RapidCue system. The tool designed to achieve the conversion and migration of EZQ data into RapidCue is the EZQ-EXPORT application.

About This User’s Guide

The EZQ-EXPORT User’s Guide provides an introduction to the application and instructions for its use. The primary purpose of this guide is to instruct cue sheet providers how to effectively consolidate and convert their EZQ data into a RapidCue acceptable format and migrate that information to RapidCue.

Since providing consistent information about series, titles and members is an integral part of building a reliable cue sheet repository, this guide also explains how to clean up any inconsistencies. In fact, the data cleanup phase is the most important phase of any migration task.

As a result, this user’s guide:

· Provides an introduction to the EZQ-EXPORT application

· Defines special terms that may be used when referring to the application

· Familiarizes users with the EZQ-EXPORT windows

· Instructs users in the steps required to set up the EZQ-EXPORT application

· Explains how to clean up series, title and member data

· Describes how to export and transmit that data to the RapidCue system

In addition to these topics:

· A glossary has been included to provide definitions for certain terms used within this document

· An index facilitates use of this document

Who Should Read This User’s Guide

The EZQ-EXPORT User’s Guide is intended for anyone who will be migrating EZQ cue sheets to the RapidCue system. The steps outlined are not merely suggestions, but rather are to be strictly followed in order to guarantee data integrity.

System Requirements

To run the EZQ-EXPORT application, you must have at least:
· A 486 computer or higher running a Windows operating system (Windows 95 or higher)

· A VGA color monitor or higher

· A minimum of 64 MB of RAM

· Microsoft Internet Explorer version 5.0 or higher

· An active Internet connection

Understanding Document Conventions

The following typographic conventions are used throughout this guide.

	Italic
	Signals a new term. Typically, a definition follows the italicized item. Also can designate a menu item or window name.

	Italic-Bold
	Indicates an application name.

	Underline
	The letter you press, in conjunction with the ALT key, to initiate a command using the keyboard, rather than the mouse.

Underlining is also used to emphasize a given phrase or concept.

	KEY1+KEY2
	A plus sign (+) between key names means to press and hold down the first key while you press the second key. For example, “press ALT+F4” means to press and hold down the ALT key and press the F4 key, and then release both keys.


Chapter 1. Introducing EZQ-EXPORT
EZQ-EXPORT Overview
The main purpose of EZQ-EXPORT is to allow you to electronically migrate your cue sheet data to the RapidCue system. This is intended to be a one-time event. That is to say, after exporting EZQ data to RapidCue, you should no longer use EZQ for the maintenance of cue sheet information. The application presents cue sheet data in terms of series/episode windows, organization windows, title windows, member windows and comparison windows. The application allows you to open any number of databases at one time. The core functionality of the application can be divided into two areas:

· Data cleanup

· Export 

The first area (data cleanup) includes the following tasks:

· Use of the Analyze References feature to delete broken member, title and organization references within each database. A broken reference is a data item (organization, title or member) that is in a database reference table, but does not appear on any cue sheet in that database.

· Use of the Analyze Duplicates feature to merge members, titles and series where appropriate within each database or between two databases. The merging of two or more members means to eliminate all variations (i.e. inconsistent spellings) of a member name, except for the one that you indicate to be correct. All references to the eliminated member names (or duplicates) will be reassigned to the one that you had indicated as the correct one (or original). The same concept exists for titles and series.

· Use of the Compare feature to merge identical members, titles and series between two databases. Identical members are member names that are spelled exactly the same. This feature is necessary so that identical members in two different databases are internally flagged as the same entity. Hence, when both databases are eventually exported to RapidCue, duplicates will not result. The same concept exists for titles and series. 

The second area (export) includes the remaining tasks:

· Use of the Export feature to export each series within each database. The term export means to convert the EZQ data into a RapidCue acceptable format. Each export results in one export file. This file is then then transmitted to the RapidCue site. The site is actually an FTP site from which the file will be picked up and processed.

Navigating through EZQ-EXPORT

This section is only a brief tour. You should not do any work until you have followed all of the steps in the chapter entitled Getting Started. The EZQ-EXPORT application is based on a multiple document interface model, meaning that you can open many resizable windows within the application main window. The main window initially appears with the following menu:

[image: image1.png]Main window caption Minimize main window:

—Display the application "About" box. Maximize main window-




By clicking the File menu item or by pressing ALT+F the initial file menu drops down:
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The New menu item allows you to open an EZQ database file in a new child window. A child window is a window that exists within the frame of the main window. By clicking the Preferences menu item or by pressing P with the drop down displayed, the Settings sub menu item is selectable. Click on it or press S to specify your settings.
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It is necessary to verify the user settings prior to opening any files and doing any work.
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The above settings are stored in an encrypted configuration file. Since the file is encrypted, no one can gain access to the security information that it contains (i.e. user name and password).

Once you have specified your settings, you may proceed to open databases in order to do work. If you select the File and New menu item, the following file dialog will allow you to select an EZQ database:
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If you select a database file to open, the series and episodes in the file will be displayed in a child window. Once a child window is opened, other actions are available to you through more menu items.

The broken member, title and organization reference windows can be viewed by selecting the appropriate menu item with the mouse, by pressing ALT+T followed by A R and M, or by clicking the appropriate button in the upper right corner of the series/episode window.
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All broken reference windows have the same “look and feel”. The window is sizable and information is presented in a grid. You can delete rows by selecting a range with the mouse or by pressing SHIFT + DOWN ARROW. Then you can right click the mouse for the Delete popup menu item. When something is deleted, it is removed permanently and can never be restored.
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It should be noted that all grids in all windows have sizable columns. You can click and drag the end of any column to either shrink or expand it.
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Additionally, all grids can be sorted by any column and are scrollable. Simply double click on the column to sort the grid by that column. All windows are scrollable as well, and can be automatically arranged by selecting a sub menu item from the Window menu.
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EZQ-EXPORT Help
This User’s Guide is available through the Help menu. Moreover, should your organization’s support staff need technical details in order to resolve a problem, the Help menu’s About EZQ-EXPORT sub menu item provides in-depth technical information. 
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Notice that the current version of the application is also displayed.
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The system information is organized by type (i.e. summary, hardware, software, etc.) as represented by folders.
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Chapter 2. Getting Started

Installing EZQ-EXPORT

To install EZQ-EXPORT on your computer:

1. Access the FTP website ftp.ascap.com in order to download the installation file.

2. The user name is external and the password is install.

3. Navigate to the folder EZQToRapidCue.

4. Copy the installation file EZQ Export Setup.exe to your computer.

5. Double click the file just copied to your computer.

6. Follow the instructions in each step.

Starting EZQ-EXPORT

To start the EZQ-EXPORT application:

1. Double click on the desktop icon.

2. Alternatively, click the Start button in the Windows taskbar.

3. Expand the Programs sub menu and select the EZQ-EXPORT application from the location specified during installation.

Setting Up EZQ-EXPORT

The very first time that you start EZQ-EXPORT, you must set up the application for your use. You are automatically provided with an FTP site, folder, user name and password. You must confirm that information and provide your creator id and email address where indicated. 
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Your Company and creator id correctly identifies your data to the RapidCue system, and your email address is necessary so that you can receive electronic acknowledgements. Once you have supplied your Company, Creator id and Email address, click the (+) plus sign to save. Then click the back arrow to return to the main window. Also note that the creator id is defaulted to 0000. Before you start using the system, you are expected to change this id. If you forget to change, then the system will remind you about this before transmitting the file to RapidCue site. You can also change it then. The transmit mode will identify the export file transmission mechanism. If automatic is selected, the application will automatically upload the file. If you intend to transfer XML files manually or if automatic mode is not working due to corporate firewall issues, select manual as transmission mode. 
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NOTE: It is absolutely necessary that you make a copy of all of your EZQ databases prior to opening any database with the EZQ-EXPORT application. The EZQ-EXPORT application alters each database that it opens for the very first time, stamping it with a unique database id and adding certain other audit fields to its tables. Hence, you should keep your original EZQ databases in a safe place and only work with the copies.
Closing EZQ-EXPORT

To exit the EZQ-EXPORT application at any time, you can do any one of the following:

1. Choose Exit from the File menu.

2. Click the X in the control menu box [image: image15.png]


 in the upper right corner of the main window.

3. Press ALT+F4 with all child windows already closed.

Chapter 3. Cleaning Up Data

Cleaning Up Individual Databases
The first step that you must perform is to normalize the data in each database. This means that you must make sure that there is no inconsistent and duplicate data in the database. Later, you will use the merge feature to accomplish the bulk of this task. However, if you wish to additionally eliminate unused data, you may optionally cleanse your database of any broken references. Broken references are titles, members and organizations that are not used in any of your cue sheets. Please note that unused titles, members and organizations will never be exported along with your cue sheets. Hence, this particular task is optional and is only included in the functionality for those users who wish to archive a completely normalized version of their data.

Broken Title References – Unused Titles

The unused titles are also accessible through the broken reference feature. You can either click the broken title button on the top right of the Series/Episode window or use the Tools menu. If you are going to remove unused data, you should first clean up unused titles.
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The broken title reference window looks and behaves exactly as the broken member reference window. The following paragraphs explain that functionality in detail.

Broken Member References – Unused Members

Unused data consists of members that are not used in any entitled party lists, titles that are not used on any cue sheets, and organizations that are not referenced. Deleting unused data is optional. However, in addition to reducing the size of your database, it takes very little time and effort. 

Start the EZQ-EXPORT application and open a database with the File, New menu item.
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The unused members are accessible through the broken reference feature. You can either click the broken member button on the top right of the Series/Episode window or use the Tools menu.
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Once you click the appropriate menu item or button, the broken member reference window will appear. This window may take a moment to load.
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Once the grid is loaded you will see all unused members.
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You can select a row by clicking on it. If there are more than one row, you can select a range of rows by holding down the left mouse button and dragging the mouse either up or down. You can also select a range by pressing SHIFT+DOWN ARROW or SHIFT+UP ARROW. Once a row or range is highlighted, right click on the grid to popup the delete menu. 
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Once you delete a row, it is permanently removed from the database. Therefore, you will be first prompted to confirm the delete operation.
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The grid will then be refreshed and the deleted item will no longer be visible. Once the grid is empty, you have successfully removed all unused members from the database.

Broken Title References – Unused Titles

The unused titles are also accessible through the broken reference feature. You can either click the broken title button on the top right of the Series/Episode window or use the Tools menu.
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The broken title reference window looks and behaves exactly as the broken member reference window.

Broken Organization References – Unused Organizations

The unused organizations are also accessible through the broken reference feature. However, can only invoke this window through the Tools menu. There is no corresponding button on the Series/Episode window.
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The above shows how you can highlight and delete a range of rows in a broken reference window.
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Upon confirmation, all rows in the grid will be deleted in one step. This completes the clean up of all unused data.

Duplicate Members

Duplicate data consists of members, titles, organizations or series that represent the same exact entity and 1) are spelled exactly the same or 2) are spelled inconsistently. For example, in the case of members, the following members are duplicates because they all represent the exact same entity:

1. ASPENFAIR MUSIC INC.

2. ASPENFAIR MUSIC INC

3. ASPENFAIR MUSIC, INC

4. ASPENFAIR MUSIC, INC.

5. ASPENFAIR MUSIC

6. ASPENFAIR

You must decide the way that you want this member to appear in RapidCue.  Then use that member as the original (the authoritative spelling) when merging duplicates (the other variations). There are two windows that enable you to resolve duplicates. The first is the Duplicate Member window, the second window is the Compare window. The Compare window is used later on in order to reconcile many duplicates across two databases in just one step. The Duplicate Member(Writer/Publisher/All) window is used in order to reconcile duplicates one case at a time within the same database or across two databases. This window is used in the first step of the clean up process. Note that Members are subdivided in Writer Type, Publisher Type and All.

A complete list of all members is accessible through the duplicate member window so that you may identify duplicate cases. You can either click the duplicate member button on the top right of the Series/Episode window or use the Tools menu.
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It may take a few moments for the member window to load, depending upon how many members are in the database.
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There are potentially many members in a particular database. Therefore, you need to approach the duplicate clean up in as orderly and thorough manner possible. There are at least two ways that the application assists in this task. Firstly, the contents of the grid can be printed to a file. You can then use the printed list as a mark up, crossing off members as they are cleaned up. 
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After clicking the print to file button, select a name and location for the file.

[image: image32.png]| E2Q-EXPORT

Fle Edt Vew Toos Window fep

Lookin |3 E20 Evpont 20 o] « &k E-

r
A
a—d

A
&
=

My Computer

[ belp_fies:

Compuc [N 5 =
G e I

I~ Open as eadorly

=1olx]





The View menu item in the main window allows you to view and print any reports that you create. After saving the report, click the View and then Report menu item.
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Then navigate to the report file that you previously saved and it will appear in NotePad. You can print it from NotePad.
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Secondly, you can opt to display only subsets (smaller portions) of the member data in the grid by filtering with search text. Filtering means to limit the members that are displayed in the grid based upon the text entered in the search text box at the bottom of the window.
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The search feature is very powerful. The simplest way to search is to first click on the column upon which the search will be based – in this case “Member”. Then type part of the member name into the text box. Finally, click the refresh button on the lower right of the window. According to the above window, the application will look for all members that have the string (group of letters) ASPEN in their name. Double clicking the text box brings up help box which tells how to use the search feature. Double clicking again on the search box removes the search help box. Single clicking on the search box also removes the search box.
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Deciding which ASPENFAIR music is the correct and authoritative one may not be a simple matter of spelling. Hence, you may need to see in which roles (publisher, composer, arranger, etc.) this member has been cast in entitled party lists. You can select the the Role column in order to drop down a list box of the roles for a particular member. By default it mentions one of the roles for that member. Alternatively hovering the mouse over the column also displays associated roles in a tooltip box.
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You can also drop down all of the titles that have entitled parties using that particular member name.
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You can also drop down all of the episodes in which there were cue titles that had entitled parties using that particular member name.

NOTE: It is of the utmost importance that your merge does not result in the same member appearing more than once in an entitled party list for a particular title. Hence, use of the title drop down list is essential.
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Once you have decided, you can select the original (authoritative) member.
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The text color of this member will then be changed to blue, signifying that it is the original.
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To deselect a selection right click on that row and again click on Duplicate. This will deselect the member row. The Duplicate menu is a toggle menu.
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The text color of the duplicate members will be changed to red. Then you can right click anywhere in the grid in order to merge the members.
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You must then confirm that the merge operation is correct.
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Finally, only the original member remains in the database. All entitled parties that referenced the other member names now use this original member name.
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You should continue in this manner until all other duplicate members are appropriately merged. It should be noted that much more elaborate search strings are possible by use of wildcard characters. The asterisk (*), question mark (?), number sign (#), exclamation point (!), hyphen (-) and brackets ([]) are wildcard characters. You can use these characters in searches to include all members that begin with specific characters or match a certain pattern. The following table summarizes the use of wildcard characters in searching.

	Symbol
	Example
	Usage

	*
	wh* finds what, white and why
	This symbol matches any number of characters.

	?
	b?ll finds ball, bell and bill
	This symbol matches any single character.

	#
	1#3 finds 103, 113 and 123
	This symbol matches any single digit.

	[ ]
	b[ae]ll finds ball and bell but not bill
	This symbol matches any single character within the brackets.

	!
	b[!ae]ll
	This symbol matches any single character not in the list.

	-
	b[a-c]d finds bad, bbd and bcd
	This symbol matches any one of a range of characters.


Note that the wildcard characters ( *, ?, #, [ ) can match themselves only if enclosed in brackets. For example, to search for a question mark, you would enter [?] as the search text.

Duplicate Titles

A complete list of all titles is accessible through the duplicate title window so that you may identify duplicate cases. Duplicate titles are eliminated in exactly the same manner as members. The duplicate title window is displayed by clicking the duplicate member button or through the Tools menu.
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The drop down lists in the duplicate title window assist in identifying whether a title is indeed a duplicate. All of the entitled parties associated with the title and all episodes that use that particular cue title are also viewable in drop down lists. Alternatively just hovering the mouse over the party will list the entitled parties in the tooltip box as shown below
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Duplicate Organizations

The Duplicate Organizations window is strictly for informational purposes. Duplicate organizations can be viewed but not merged. The reason for this has to do with the internal structure of EZQ databases. If duplicate organizations exist, they will not pose any problems for the export process. To view duplicate organizations, you must use the Tools menu.
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Duplicate Series

The first window that appears when you open a database is the Series/Episode window. All of the series, episodes and standalone program that have not yet been exported appear in this window. Duplicate series are cleaned up in the Series/Episode window in exactly the same manner as members and titles. The only difference is that only one duplicate series at a time may be selected and merged. Moreover, only series may be merged. There is no facility to merge episodes.
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In this instance, WALKER, TEXAS RANGER is being selected as the original series. Then you would select the other row with the series name WALKER as the duplicate.
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You can then merge the selected items. Once again, you will be prompted to confirm the merge.
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Deleting Episodes

Once again, there is no facility through which to merge episodes. If you notice a duplicate episode, then you may simply delete that episode. Furthermore, if you wish to delete an entire series, then you may delete all of the episodes for that series. You can select the episodes for deletion and then permanently remove the episodes from the database through the “Delete” popup menu.
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Since the data will be permanently removed, you are prompted for a confirmation.
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The row is no longer in the grid.

[image: image62.png]=1BIx|

Flo Edt Vew Toos Window Help

il

I CADEVELOPHENTEZE EXPORT
20DATABASES\I866-133MDB

AN A

Sefes e TEpkode /Frogam Nams
CAROLINE I THE CITY CAROLIE & THE
CAROLINE I THE CITY CARDLINE & THE 847
CAROLINE I THE CITY CARDLINE & THE 54
CAROLINE I THE CITY CAROLINE & THE 816 NIGHT
CAROLINE I THE CITY CAROLINE & THE 816 NIGHT
CAROLINE I THE CITY CAROLINE & THE 85, 820
CAROLINE I THE CITY CAROLINE & THE 85, 840

CARDLINE IN THE CITY CAROLINE & THE BODBY

[

NETWORK SERIES
NETWORK SERIES
NETWORK SERIES
NETWORK SERIES
NETWORK SERIES
NETWORK SERIES
NETWORK SERIES
NETWORK SERIES

erson =
EDITED FOR TV

INTERNATIONAL
INTERNATIONAL
EDITED FOR TV,
EDITED FOR TV,
INTERNATIONAL
INTERNATIONAL

enimen ena n/_"ll

Search Text:

S43R0WS

CIJENGEY




This concludes the clean up of one entire database. This clean up must be performed on each of your databases. Next, you will be merging member, title and series data across each of your databases.

Reconciling Multiple Databases
The EZQ application uses individual database files to store its information. This means that you can create many separate EZQ databases that contain cue sheets for the same series but for different seasons. RapidCue, in contrast, uses one only repository for your organization’s cue sheets. The consequence of the difference between the two systems is that you must reconcile the data between all of your EZQ databases prior to exporting to RapidCue. To reconcile the data across multiple databases means to merge all appropriate members, titles and series so that duplicate data is not exported to RapidCue.

NOTE: If you have five databases, then you must reconcile the first with the second. Then you must reconcile the third with the first and second. Next, you must reconcile the fourth with the first, second and third. Finally, you must reconcile the fifth with the first, second, third, third and fourth.

Member Merge

Members are merged in same manner as they were in a single database. The difference is that in the case of multiple databases you will select an original from one window and then the duplicate in another.

Firstly, you must open two databases.

[image: image63.png]Fle Edi View Toos Window Help

e B

Open
Prfarences » =2 5] =]
= 5 Epiod / Pogram Nane [ Type [Verson E

ACTVATE YOUR CHOICES  NETWORK SEFIES | DOMESTIC
Zsecken BECKER THE ELDER NETWORK SERIES | DOMESTIC
3[secken CHODSE ME NETWORK SERIES | DOMESTIC
alsecken OITYLIGHTS NETWORK SERIES | DOMESTIC
Blsecken DRIVE THEY S4ID NETWORK SERIES | DOMESTIC
Blsecken LARRY SPOKE NETWORK SERIES | DOMESTIC
7|secken UMITS &BOUNDAFIES  NETWORKSERIES | DOMESTIC
olsecken LOVEIUESIBLEEDING]  NETWORKSERIES  DOMESTIC

o Ve na NETWRRK SERIES  mAMEGTIC _"_I

seachten [





[image: image64.png]7+ E2Q-EXPORT

Fle Edt Vew Toos Window fep

=1olx]

[£2q PC Database File:

Lookin: |3 Databases -] «@&ck

Sample-04.mcb

Ferare:  [ramzmnme

I~ Open as eadorly

|

Files of type: E20 Database (~mb) =





[image: image65.png]=lolx|

I 3857837 CADEVELOPMENT\EZ EXPORT =|=

= ESEE A A

Setes Nams [ e R T TVerson =

75? [P SERIES & EPISODES ol:

el Id: 6130174 CADEVELOPMENTAEZD EXPORT = =

s ESJEE A
GEl Seres Nams [Epiode / ProgamName [ Type TVerson =
i £ 3| BECKER BLIND CURVE NETWORK SERIES DOMESTIC





You can then proceed to view all members in each database by clicking the duplicate member button on each Series/Episode window or through each window’s Tools menu.

The following shows how you would merge ACUFF-ROSE MUSIC, INC. in database 3857837 (top) with the same member name in database 6130174 (bottom). Of course, the member in the top database has been indicated as the original.
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The member in the bottom database is being flagged as the duplicate in this case.
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The confirmation box then prompts whether to proceed or not.
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A search for ACUFF-ROSE MUSIC, INC. in the second database shows that it is there but now it is internally linked to the ACUFF-ROSE MUSIC, INC. in the first database. The two members have been merged and you are on your way to reconciling both databases.
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Title & Series Merge

Titles and series are merged in the same manner as members. The same type of merge operations must be performed on all members, titles and series across all databases in order to reconcile items that represent one and the same entity. If the title HAPPY DAYS ARE HERE AGAIN appears in one database and another database also contains the title HAPPY DAYS ARE HERE AGAIN, then those titles must be merged if they indeed represent the same published work. In the case of titles, identical entitled parties and similar spelling are usually indicative of two titles representing the same work.

The clean up effort across all databases can mean a very significant volume of work if you have many large databases. In order to make this task more manageable, the EZQ-EXPORT application offers the compare feature.

Compare

The compare feature will compare two opened databases and present all members, titles or series that are spelled exactly the same in both databases. These most likely represent one and the same entity. In such case, they should be merged. The Compare sub menu is available through the Tools menu.
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The similar members from both databases will be displayed side by side in one grid. Therefore, the prompt asks which database will be assumed to have the original members and which the duplicate members. In this case, database 3857837 will be assumed to be the source (the one that contains the original member names) and database 6130174 will be assumed to be the target (the one that contains the duplicate member names). If you click No to the prompt, you will swap the source and target until finally clicking Yes or Cancel. After clicking Yes, the Compare window is displayed.
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The drop down title list shows all titles that have entitled parties using this particular member name. The same drop down is available next to the Duplicate Member column as well.
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You may mark the member for merging by right clicking anywhere in the grid once you have clicked on a row. You can also select a range of rows to mark for merging if it is convenient to do so.
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The row that you marked will be displayed with green text.
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You next need to select the merge button in the lower right corner of the window.
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The member disappears from the grid once it is merged. 
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The same compare feature and the same procedure can be used for merging titles and series.

Chapter 4. Exporting Cue Sheets

EXPORT Overview
The export phase of the migration process converts the normalized EZQ data into files and transmits them electronically to the RapidCue site. The export files are in XML format. XML is the abbreviation for Extended Markup Language and is the basis for data exchange in the Internet world. 

Selected data is exported by episode. This means that if you wish to transmit each series in a database, you will select all of the episodes for that series for export. It should be stressed that once an episode is exported and transmitted, it is not removed from the database, but is permanently removed from the grid. It is not normal practice to export the same episode twice as this would result in duplicate cue sheets in RapidCue. However, in the very exceptional case where you are instructed by the RapidCue technical support team to resubmit an export file, there is a way to view previously exported episodes.

Incidentally, stand-alone programs are treated in exactly the same manner as episodes of series. The only visible difference is that stand-alone programs do not have a series name associated with them.

Exporting Episodes

You first need to select the episodes that you want to export in an export file. You can select them from the Series/Episode windows grid by clicking the left mouse button and dragging either downward or upward. Alternatively, you can select the first row and then hold the SHIFT key down while pressing the down or up arrow. Then you must right click anywhere in the grid and select the “Current” popup menu item in order to start the export process for  selected rows. Note that clicking the “All” popup menu item will result in the contents of the entire grid being marked for export.
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When you click Current or All the buttons you will be prompted to confirm the export.
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If you click Yes, then two processes get executed. First an XML file gets created for the records selected. After that the created file gets transmitted to RapidCue ftp site.

The bars at the bottom of the window will indicate percentage completion as the file creation progresses. The first bar indicates percentage completion of various export sub tasks, and the second bar indicates the overall percentage completion.
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After the file has been created locally, the file transmission process starts. In this process, the newly created XML file is electronically uploaded to Rapid Cue ftp site. The entire process is seamless and nothing extra needs to be done.

When the file gets transmitted successfully, you will see a message telling so. It also tells the name of the file which was generated and eventually transmitted. Please note that export will not be available until an email notification is received.
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If for any reason, the XML file needs to be resubmitted at any later time, the ReSubmit option enables this functionality.
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On clicking Resubmit, a dialog box asks for the file to be resubmitted.
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Select the file and click on Open. This will start the transmission process and on successful completion gives out a message saying its status.
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Viewing Export Related Information

If you want to view the actual exported file for some reason, you can do so through the View menu.
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All export files are stored in the “Output” folder located under the folder in which you installed the EZQ-EXPORT application. Note that the export files are automatically named.
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The XML format is human-readable which means that it consists of alphabetic and numeric characters. However, it is intended for electronic processing and there is no need for you to examine this file.
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Nonetheless, there is a log file containing audit information for each export. The log file is named exactly the same as the export file but has a .log extension. The export log files also reside in the “Output” folder. You may view the file through the View menu.
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This file is also printable since it is displayed in NotePad.

[image: image91.png]4] E20-016-20050903-105659.I0g - Notepad,

Fle Edt Format Help

~=lolx|

EXPORT ON 09/09/2005 10:57:21

DATABASE ID 3857837

DATABASE NAME C:\DEVELOPMENT\EZQ EXPORT 2.0\DATABASES\1998-1090.MDB
IOVERRIDE off

[The following programs were exported for

sender code: 16
sender Telephone:

sender Fax:

sender address 1
sender address 7:
sender Name:

1515 BROADWAY 49TH FLOOR
NEW YORK NEW YORK 10036-5794

sender country: usa
versior 3.0

patabase 1 3857837
series name: BECKER

Series code:
program name
program code

99541552036080000000009
BECKER THE ELDER
00001384380010000002500

Program Type 120
Production vea 1509
Production Code: 40215

Episode Code: o1l
syndicator Nimber :

[«





It is also possible to view a running history of all work performed on this database (deletions, merges and exports).
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The history log is also printable since it too is displayed in NotePad.
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MERGE ON 09/01/2005 14:46:47 E|
DATABASE ID 3857837 »>
3857837

DATABASE MAME C:\DEVELOPMENT\EZQ EXPORT 2.0\DATABASES\TESTING\1098-1099.MDE >>
C\DEVELOPMENT\EZQ EXPORT 2.(0\DATABASES\TESTING\1998-1399.MDB

[The following members were merged:

[00200352000070000000006] JACK ALLOCCO >>
[00200352000070000000007] JACK ALLOCCO
[00200352000070000000006] JACK ALLOCCO >>
[00202302236040000000006] JACK ALLOCCO
[00200352000070000000006] JACK ALLOCCO >>
[00202302236040000000007] JACK ALLOCCO

lassociated series/prograns:

[THE YOUNG AN 6460 09/10/1998
[THE YOUNG AN 6500 11709/1998
[THE YOUNG AN 6301 11710/1998
[THE YOUNG AN 6307 11718/1998
[THE YOUNG AN 6513 11727/1998
[THE YOUNG AN 6515 12/01/1998
[THE YOUNG AN 6516 12/02/1998
[THE YOUNG AN 6517 12/03/1998

ITHE YOUNG AN 6518 12)/04 /1008 _';I
‘ | »





A printable error log may be useful in instances where you experience a serious problem and need to give technical support personnel detailed application information. This log can also be accessed through the View menu.
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08/30/2005

08/30/2005

11:26:55

l421” ahortad

11:20:55

l421” ahortad

Send Cannot put Tile on site: 421-Access denfed - wrong User foal

TransmitFile: Send Cannot put File on site: 421-Access demied

09,/01,/2005 17: setgridvalues: DAo.Fields Ttem not found in this collection
05/01/2005 17 Fillselectarid: SetGridvalues: Dao.Fields Ttem not found in th
05/01/2005 17 RefreshselectGrid: FillselectGrid: Seteridvalues: pao.Fields T
05/01/2005 17 openFile: RefreshselectGrid: FiliselectGrid: Setoridvalues: ba
05/01/2005 17 Setgridvalues: DAO.Fields Ttem not found in this collection
05/01/2005 17 Fillselectarid: SetGridvalues: Dao.Fields Ttem not found in th
05/01/2005 17 RefreshselectGrid: FillselectGrid: Seteridvalues: pao.Fields T
05/01/2005 17 OpenFile: RefreshselectGrid: Filiselectorid: setoridvalues: ba
05/01/2005 17 FillselectGrid: DA0.Database The SELECT statement includes a r
05/01/2005 17 RefreshselectGrid: FillselectGrid: DAG.Database The SELECT sta
05/01/2005 17 openFile: RefreshselectGrid: FiliselectGrid: Dao.Database The
05/01/2005 17 Setgridvalues: WSFlexarid subscript out of range

05/01/2005 17 Fillselectarid: Setgridvalues: MSFlexcrid subscript out of ram
05/01/2005 17 RefreshselectGrid: FillselectGrid: setGridvalues: MsFlexcrid s
05/01/2005 17 openFile: Refreshselectorid: Filiselecterid: setridvalues: ms)
05/01/2005 17 Setgridvalues: WSFlexarid subscript out of range

05/01/2005 17 Fillselectarid: Setgridvalues: MSFlexcrid subscript out of ram
05/01/2005 17 RefreshselectGrid: FillselectGrid: seteridvalues: MsFlexcrid s
05/01/2005 18 GetRoles: DAO.Database The SELECT statement includes a reserve
05/01/2005 18 Displaysuscr1d; Getholes: DAO.Database The SELECT statament in
05/01/2005 18 MSFlexGridselect_Entercell: bisplaySubGrid: GetRoles: DAO.Dataly)
« >





Previously Exported Episodes

In the exceptional case that you are instructed to recreate an export file, you can view previously exported episodes through an option in the File menu’s Preferences sub menu.
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This option will be checked once it is activated.
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Now, when you refresh the grid, previously exported episodes will appear. They will be dimmed as a visible indication of their exported status.
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Opening Another Database

You can always open a different database in the same Series/Episode window through the File menu. This may be advantageous if you have limited screen space and want to work with only one opened window at a time. In this case, you can simply select the Open sub menu item as opposed to New.
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Chapter 6. Support

Technical support is available if you experience any serious problems while working with the application. For example, if you are unable to send your files for some unknown reason (an application error, loss of connectivity to the RapidCue site, etc.) you may contact support at the following email address:

info@rapidcue.com
When sending email describing a problem, attach the application error log and the history log for the particular database with which you were working.
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